萝卜头IT论坛

了解更多
搜索
楼主: _lizijian_
收起左侧

[已解决] 我的移动硬盘装了windows&macos双系统,windows跳硬盘进本地系统

[复制链接]
发表于 2019-2-11 09:31:49 | 显示全部楼层
本帖最后由 phyuzhoukai 于 2019-2-11 09:39 编辑

你是不是装clover的时候把ESP格式化了,导致WTG的EFI引导没了?去ESP分区检查一下,如果找不到\EFI\Microsoft的话,修复一下引导应该就可以了。
(如果用cmd命令修复的话,备份一下EFI\boot,修复完后替换回去就可以了,要不然clover引导会变成Winbootmanager)


修复命令:Bcdboot X:\Windows /s Y: /f UEFI(X为WTG盘符,Y为ESP盘符,先把ESP分区分配一下盘符)
回复

使用道具 举报

 楼主| 发表于 2019-2-11 10:24:50 来自手机 | 显示全部楼层
phyuzhoukai 发表于 2019-2-11 09:31
你是不是装clover的时候把ESP格式化了,导致WTG的EFI引导没了?去ESP分区检查一下,如果找不到\EFI\Microso ...

我的wtg装完后没有自动生成esp分区我就自己建立了一个供clover用
回复

使用道具 举报

发表于 2019-2-11 12:37:38 | 显示全部楼层
_lizijian_ 发表于 2019-2-11 10:24
我的wtg装完后没有自动生成esp分区我就自己建立了一个供clover用

感觉上就是引导的问题。你修复一下试试。引导win需要WBM的,过程是clover.efi引导bootmgfw.efi再引导BCD文件启动WIN,你现在用clover引导的应该是本地磁盘上的bootmgfw.efi,需要在移动硬盘上再建立一套WTG的引导文件,过程已经在上个回复说了。
回复

使用道具 举报

 楼主| 发表于 2019-2-11 20:47:48 | 显示全部楼层
phyuzhoukai 发表于 2019-2-11 12:37
感觉上就是引导的问题。你修复一下试试。引导win需要WBM的,过程是clover.efi引导bootmgfw.efi再引导BCD ...

WBM是啥?我的clover是macos格式的
回复

使用道具 举报

发表于 2019-2-11 21:46:05 | 显示全部楼层
_lizijian_ 发表于 2019-2-11 20:47
WBM是啥?我的clover是macos格式的

就是windows boot manager。Clover没有什么macos或者win格式,引导就靠一个clover.efi文件,平台通用的。你按我说的试试看,先挂载esp分区,看看efi文件夹下有没有microsoft这个文件夹,如果没有那基本就是引导的问题(你也说了装完wtg没有自动生成esp)。然后把efi下的boot文件夹备份一下,等会要替换回去。登录你本地硬盘上的win系统,挂载好移动硬盘的esp分区,比如Y盘,以管理员权限打开cmd输入命令Bcdboot X:\Windows /s Y: /f UEFI(X为WTG盘符),然后把efi的boot文件夹替换回去,应该就可以了。
回复

使用道具 举报

发表于 2019-2-11 21:49:37 | 显示全部楼层
_lizijian_ 发表于 2019-2-11 20:47
WBM是啥?我的clover是macos格式的

还有一个简单一点的办法是,把你本地硬盘上引导分区内的efi\microsoft文件夹复制到移动硬盘esp的efi文件夹下,用bootice修改一下BCD文件,使其指向移动硬盘上的WTG就可以了。
回复

使用道具 举报

发表于 2019-2-12 09:36:38 | 显示全部楼层
这个太复杂了吧,一个盘搞那么多系统,一不小心都挂了又要重做
回复

使用道具 举报

 楼主| 发表于 2019-2-12 12:13:57 | 显示全部楼层
yjhjrh 发表于 2019-2-12 09:36
这个太复杂了吧,一个盘搞那么多系统,一不小心都挂了又要重做

没错,这是第4次重做了
回复

使用道具 举报

联系站长|手机版|萝卜头IT论坛 ( 苏ICP备15050961号-1 )

GMT+8, 2019-4-23 06:41 , Processed in 0.111340 second(s), 33 queries , Gzip On.

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表